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MPLAB X + CCS C Compiler Tutorial

How to install the CCS C Compiler inside MPLAB X

Before the CCS C Compiler can be used inside MPLAB X, the CCS C MPLAB X Plug-in
must be installed. This process can be done inside MPLAB X.

1. Launch MPLAB X.
2. From the MPLAB X menu, select Tools -> Plugins
3. Verify that MPLAB X is searching Microchip's Third Party plug-in repository. This

can be done by selecting the Settings Tab in the Plugins window and verifying that
Microchip Third Part Plugins is available and checked.

Plugins E|

Updates | Available Plugins (15) | Downloaded || Installed (23‘ Settings| ,
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Advanced
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4. Goto the Available Plugins tab. Check the box next to CCS C Compiler. Once
checked, press the Install button.

o . ==
—————

Update{| Available Plugins (16) |§:wnlcaded | Installed (28) I Settingsl
4
Install Name i . Category \? Source |} €CS C Compiler

[[]  dsPICFilter Designer MPLAE Plugin i

[l oma MPLAE Plugin @:ﬁ' m Community Contributed Plugin

[C]  PCLint MPLAB Plugin [l

[C]  Power Monitor MPLAB Plugin @ || version: 1.56

[[]  MPLABX KeeLog Plugin MPLAE Plugin Eﬁfﬁl Author: CC5, Inc.

I I:‘ ECAM Bit Rate Calculator MFLAE Flugin [D:ﬁl Date: 1/28/14

[[] MPLAB® Code Configurator MPLAB Plugin gy | |5ource: Micrachip Third Party Plugins

[C]  Proteus VSM Viewer MPLAB Plugin o | |Homepage:htto:/fwivw.cesinfo.com/

[7]  Graphics Display Designer X MPLAB Plugin from]

[[]  MemoryStarterkit MPLAE Plugin [l Plugin Description

I [[]  dsPICWorks MPLAB Plugin i
[[]  RTOS Viewer (FreeRTOS) MPLAE Plugin @ﬁ, CCS_pro_vides a n:_omplete _integr_ated tool suite for developing and _debL.!gging embedded
O] P8P Tool Chain Tools ‘ﬁFﬁ' apqllc_a_tlons running on Micrachip PIC MCUs and dsPIC D5Cs, The !ntelhgen_t cod_e _
o R - A optimizing CCS C compiler frees developers to concentrate on design functionality instead

L] icfiasicLana: o of having to become an MCU architecture expert. Benefits indude maximized code reuse

easily porting from one MCU to another, minimize lines of new code by using provided

I peripheral drivers, builtin functions and standard C operators. Qur built-n functions are
spedific to PIC MCU registers, allowing access to hardware features directly from C and we
indude ready to run examples and tested peripheral drivers allow developers to quickly
start their project.

Install plugin selected, 25kB

If you do not see CCS C Compiler in the Available Plugins tab, it is possible the
plugin is already installed in your MPLABX. Skip to step 6 to verify that it is
installed.

5. After you press the Install button, a few new dialog windows will ask to verify that
you want to install the plug-in and that you accept the license.

If you get a dialog window saying the plugin is signed but not trusted, ignore it and
continue the installation of the plugin.

After the plugin is installed, MPLABX will ask you to restart the software. The plugin
will not install without MPLABX being restarted.
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6. The CCS C Compiler plugin should be installed now. Before attempting to use the
plugin, verify that it is installed. To do this open the Plugins window by selecting
Tools -> Plugins from the MPLABX menu. Select the Installed tab. Look for CCS
C Compiler, it should have the Active column checked to signify that the plugin is
installed and running.

X ==

| Updates I Available Plugins (15) | Downloadeﬂ Installed (27) | S;Ltingsl

Search:
4
Select MName Category ¥ Active c

' ccs ¢ compiler
[] Local History Base IDE a -
[ Mercurial Base IDE (V] Version: 1.57
[[] Database Base IDE V] Source: org-ces-MPLABXplug.nbm
[ subversion Base IDE (V]
[] spelichecker Base IDE (V] } L.
] IDE Platform Base IDE ) Plugin Description
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[[] Hudson Base IDE Q applications running on Microchip PIC MCUs and dsPIC DSCs. The inteligent code
[[] Team Basze IDE @ |E|||optimizing CCS C compiler frees developers to concentrate on design functionality instead

C BaseIDE of having to become an MCU architecture expert. Benefits indude maximized code reuse
by easily parting from one MCU to another, minimize lines of new code by using provided
peripheral drivers, builtin functions and standard C operators. Qur built-n functions are

Pomer Bats-Rrocessing e— specific to PIC MCU registers, allowing access to hardware features directly from C and we
[[]  PeripheralAndsFRs Ll T o inpdude ready to run esgtlample:s and tegted peripheral drivers allow deuelopgrs to guickly
[[]  toclchainCommon MPLAE IDE @ start their project,
[] toclchainMPASMWIN MPLAB IDE (V]
I:‘ toolchainXCa MPLAB IDE (V] B
D toolchainASM30 MPLAB IDE (V]
[[] toclchainHI-TECH MPLAE IDE (V]
I:‘ toolchainXC 16 MPLAB IDE (V]
D toolchainC30 MPLAB IDE (V]
[ teclchainC32 MPLAE IDE e -
Activate Deactivate Uninstall

If CCS C Compiler is missing from this window, go back to step 1 to install the plug-
in.

This window can also be used to inspect the version of the plugin. (This is the
version of the plugin, not the compiler). By highlighting/selecting CCS C Compiler,
the text description on the right will change and display the version number.
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How to create an MPLAB X project that uses the CCS C Compiler

Before attempting to use the CCS C Compiler in MPLAB X for the first time, verify that the
CCS C Compiler plug-in is installed in MPLAB X. This can be done via step 6 of the
section labeled How to install the CCS C Compiler inside MPLABX.

1. Launch MPLAB X.

2. Ensure that no other projects are open by selecting File -> Close All Projects from
the menu.

3. Start a new project by selecting File -> New Project

MPLAB X IDE v1.10
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4. MPLAB X's New Project dialog will start. It will first ask you what kind of project you
want to create. Select 'Standalone Project' and press the 'Next' button.

MPLAB X IDE v1.10 MEES

File Edit “iew MNavigate Source Refackor Run Debug Team Tools Window Help

Choose Project
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5. Adialog will ask you what PIC you want to use. Select the PIC you want to use for
your project from the pull-down selector and then press the 'Next' button.

. (MPLAB X IDE v1.10
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6. The dialog will ask you what Programmer/Debugger tool you want to use. If you are
not using such a tool, then select 'Simulator'. After you have made your selection
press the 'Next' button.

Select Tool
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7. The dialog will now ask which compiler you want to use. You should see a section
labeled 'CCS C Compiler', and under this section you may have a few CCS C
Compilers to choose from. You would have several choices to choose from if you
have installed multiple versions of the compiler on your computer at once. If you
only have one installed CCS C Compiler then you will only have one choice. Select
the 'CCS C Compiler' version you want to use and press the 'Next' button.

[- [=2]x]

Select Compiler

Choose Project

1%
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Not getting an option for CCS C Compiler here?

First, verify that the CCS C Compiler plug-in has been installed by following the first
section of this tuturial titted "How to install the CCS C Compiler inside MPLAB X".

If the plug-in is installed but there still isn't an option to select the CCS C Compiler here,
it's probably because MPLAB X doesn't know where the compiler is located. To resolve
this, find the section of this tutorial labeled "How do | add CCS C Compilers to
MPLABX's list of compiler toolchains?"
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8. The dialog will now ask you what to call the project and where to save the project.
The project directory is where MPLAB X will store configuration files for the project
and where output files generated after a compile will be stored. The source code
does not necessarily have to be placed into the project directory.

After choosing project name and project directory, press the 'Next' button.

Clslx)

New Project &|

File Edit “iew MNavigate Source Refackor Run Debug Team Tools  Window Help
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Choose Project
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5. Select Compiler Praject Location: |CtiMyProjects | [ Browse
6. Select Project N d 1

e o Project Folder: !C:IMyProjects'l,FirstJ:roject.X |

Folder
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Encoding: 130-5859-1 w ‘

Finish H Cancel ” Help

9. The New Project dialog is now finished and the project is created, but the project is
empty and there is no source code attached to the project. We now need to add
source to the project. Source can be added to the project in one of two ways:
creating a new file or adding an existing file.

» Creating a new file: Right click on 'Source Files' and select 'New -> C Main File' or
'‘New -> C Source File'. A dialog will ask you what to name the file and where to
save it.

* Adding an existing file: Right click on 'Source Files' and select 'Add Existing ltem'.
A dialog will allow you to browse your computer to chose the file to add the project.
A file chosen this way will be left in the directory it was found, it will NOT be copied
to the project directory.
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For this tutorial, ex_sqw.c from the CCS C Compiler's examples directory (if the
compiler is installed to the default directory, will be found atC:\program
files\picc\examples\ex_sqw.c) was copied to the project directory and then inserted
using 'Add Existing Item'

If you only insert one source C file into your project, MPLAB X will call the CCS C
Compiler to compile and link in one step. No intermediate .o files used for multiple
compilation units are generated.

If you insert more than one source C file into your project, MPLAB X will call the
CCS C Compiler multiple times to compile each C file seperately. After each C file
is compiled seperately, the .o output files are then linked in the final step to create
the .HEX and .COF file. This process of multiple compilation units is only supported
by licensed users of the PCW IDE. Command-line only customers do not have this

feature.
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Technical Support:

10. Compile (build) the project by selecting 'Run -> Build Project' from the menu.
'‘Clean and Build Project' can also be used, which will erase all output files and

intermediate .o files before building.

default
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11. During the build process, MPLAB X will invoke the CCS C Compiler. You should
see the CCS C Compiler window pop-up during this process (depending on the size
of your file this may disappear quickly).
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12. Compile status and compiler output messages will be displayed in MPLAB X's
output window. The output window will also display where MPLAB X saved the
result .HEX and .COF file output of the compiler.
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How do | change project properties, like the include path?
This can be done in MPLAB X by selecting 'File -> Project Properties' from the menu.
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This will open the project properties dialog. CCS C Compiler specific options can be found
in the section labeled 'Compiler Options':
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How do | add CCS C Compilers to MPLABX's list of compiler
toolchains?

Why isn't MPLAB X finding my CCS C Compiler even though | have the
plugin installed?

Option 1 — Add ccsc.exe to Window's PATH. | =ienment varisbies —
When MPLAB X starts, it searches the
computer's execution path for any compatible

User variables

. . . ' Variable Value el
compl!er toolchains. In CCS C Compiler's RS, (- Ther ARt e e et s |
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CCSCON EXE SMARTRFSTUDL... C:\Program Files (x86)\Texas Instrume...

' : TEMP SLUSERPROFILE%:\AppData'local{Temp ™

In Windows, to changing the execution path (Sr—f e ———
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Environment Variable in the Control Panel's PROCESSOR R... 0802

. PSModulePath C:\windows\system32\WindowsPowers. ..
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of the CCS C Compiler's installed directory, exit [
and start MPLABX and it will automatically find
the compiler.

oK ][ Cancel ]

Option 2 — Add ccsc.exe to MPLABX's Build Tools.

To manually add a compiler to MPLAB X that isn't in the computer's execution path can be
done from MPLAB X's Option screen. From the MPLAB X menu, select Tools->Options.
On the Options screen, select the Embedded screen and then the Buld Tools tab:
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In my project, why do | get many red underlines because MPLAB X
thinks there are a lot of syntax errors in the code?

MPLAB X treats any file with an upper case .C extension as a C++ file. Since the CCS C
Compiler is not a C++ compiler MPLAB X will trigger many valid lines as a syntax error.

Bad file: Good file:
= [gf Source Files =g Source Files
- ex_sqw.C - ex_sqw.c
-([F Libraries (@ Libraries

There are 2 possible resolutions. First, rename the file to have a .c extension instead of

a .C extension. Second, change the MPLAB X settings so a .C file is a C file and not C++.
Performing either of these steps may require you to delete your MPLAB X project and
create a new one.

To change the MPLAB X properties to make a .C file a C file, from the MPLAB X menu,
select Tools->Options. On the Options screen, select the Embedded screen and then
the Other tab:
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Contact Information
' ' - Sales and Info : 262-522-6500 x35

@ sales@ccsinfo.com

“- Technical Support:  262-522-6500 x32
support@ccsinfo.com

| have several versions of CCS C Compilers installed on my computer,
how do | tell MPLAB X which to use?

This setting is saved to each individual project. To change which compiler to use, the
project settings need to be changed. From the MPLAB X menu, select File -> Project
Properties.

Project Properties - ex sqw El
Cateqgories: Configuration
e 2 General
=0~ nif; [default] Farnily: Dervice:
e @ Simulstor All Families w | |PIC16FEET v
~- @ Loading
@ Libraries Supported Debug Header: Supported Flugin Board:
- 0 Building

B @ CCSC Compiler
i @ Compiler Options

Hardware Toal: Compiler Toolchain:
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0o 1D 3 E-CCS ¢ Campiler
00 PICKEZ © L.0CS © Compiler [CPROGR
E----oo PICKES RS C Compiler [C:PROGR,
L0 PM3 --HI-TECH PTCC (None Found)
00 Real ICE =-mpasm
Yoy il tor v | o mpasm (v5.47) [CriProgr: ¥
< > < >

*Tip: double click on serial number {SM) to use a friendly name (FM) instead,
Manage Configurations. ..

I QK H Cancel ” Apply ][ Help ]

From the Project Properties window, select the Conf category on the left side of the
window. On the right side of the window you will see all the available compilers under the
Compile Toolchain section. The full path to the compiler executable is shown with each
available compiler toolchain. Select the compiler you want to use, and press the Ok
button.

MPLAB X is able to scan your computer to find compatible compilers. But MPLAB X may
not show your compiler if it fails to find it or if you have too many different compiler
versions installed. In this condition you will have to manually add a compiler to MPLAB X's
compiler list. To do this, select Tools -> Options from the MPLAB X menu. Once the
Options window is open, select Embedded and then the Bulid Tools tab.



Contact Information
' ' - Sales and Info : 262-522-6500 x35

@ sales@ccsinfo.com
“- Technical Support:  262-522-6500 x32
support@ccsinfo.com

| have several versions of CCS C Compilers installed on my computer,
how do | tell MPLAB X which to use? (Continued)

Under Toolchain, MPLABX will list all the CCS C Compilers that it has found. You can
use this dialog window to add or modify MPLAB X's list of available compilers.

Options E|
7 @ ®B 6 || &
General Editor Fonts & Colors Kewmap ClC++ Embedded | Miscellaneous

Build Taals | Project Options | Generic Settings | Suppressible Messages | Other |
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Contact Information
Sales and Customer Service: 262-522-6500 x35
sales@ccsinfo.com
Technical Support: 262-522-6500 x32
support@ccsinfo.com
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